Modify

Ticket #92 (closed bug: fixed)

Opened 9 years ago

Last modified 9 years ago

Inventory event handling bug

Reported by: b0rland_parpg Owned by: b0rland_parpg
Priority: major Milestone: Techdemo 1
Component: scripts Version: trunk
Keywords: Cc:
Blocked By: Blocking:
Department:

Description

Steps to reproduce: 1) Open Inventory window via any possible method ('I' key or click on HUD Inventory button) 2) Close window by clicking on HUD Inventory button 3) Press 'I' to open it again

Expected result: Inventory window opens

Actual result: Nothing happens. You have to open inventory by HUD button, then close it by pressing 'close' inside the inventory dialog. Only then the 'I' button starts working again.

Attachments

Change History

comment:1 in reply to: ↑ description Changed 9 years ago by superfluid

Actually, to reproduce this all you have to do is click anywhere on the Hud in the lower portion of the screen and none of the keybinds will do anything. Maybe because Hud grabbed focus and is sucking up all the keypress events or something.

comment:2 Changed 9 years ago by b0rland_parpg

  • Owner changed from parpg to b0rland_parpg

comment:3 Changed 9 years ago by b0rland_parpg

This seems to have something to do with focus. When you click anywhere on the HUD bar, the main window loses focus and doesn't receive keypress events. When you click anywhere inside the main window, it regains the focus and keys start to work again.

comment:4 Changed 9 years ago by b0rland_parpg

  • Status changed from new to closed
  • Resolution set to fixed
  • tt_remaining changed from 1d to 0
View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.