Modify

Ticket #279 (closed enhancement: duplicate)

Opened 8 years ago

Last modified 8 years ago

No standard way to perform a system-wide install of PARPG

Reported by: Aspidites <aspidites@…> Owned by: parpg
Priority: major Milestone: Release: Techdemo 2
Component: scripts Version: trunk
Keywords: Cc:
Blocked By: Blocking:
Department: Programming

Description

Enhancement Description

A setup.py script should be added to the source tree to allow for system-wide installation of PARPG

Rationale

Pros and Cons

Pros:

  • Having a system-wide installation would allow for PARPG to be run from anywhere, and not simply from a PARPG sub-directory
  • Having a setup.py script would make it easier for Linux Distros to create binary packages for PARPG, which would increase PARPG's exposure
  • Code reuse is rather difficult if files are only local. For example, I'm developing a dialogue editor that rely's on the Dialogue modules, but access to those modules are restricted. The only way for my dialogue editor to access them is to append the location of the modules to python's path, which is clubmsy at best. Having a system-wide installation of parpg would allow for direct imports.
  • Fife allows for system-wide installation. If they do, we should as well.
  • For Linux Distros, having a setup.py script would make it easier to package PARPG.

Cons:

  • one more file added to the source tree

Other than that, there aren't any cons, considering the fact that local installs for the game itself would still be possible.

Attachments

Change History

comment:1 Changed 8 years ago by Aspidites <aspidites@…>

I contributed a setup script to Ultimate Smash Friends a while back which has since evolved dramatically. It could be modified to work with PARPG:

http://bazaar.launchpad.net/~usf-team/ultimate-smash-friends/trunk/annotate/head%3A/setup.py

comment:2 Changed 8 years ago by barra_parpg

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #275. Closed by request of ticket submitter.

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.