Modify

Ticket #276 (closed enhancement: fixed)

Opened 8 years ago

Last modified 8 years ago

Inconsistency between attributes and parameters in dialogueparsers.py

Reported by: Aspidites <aspidites@…> Owned by: technomage
Priority: major Milestone: Release: Techdemo 2
Component: scripts Version: trunk
Keywords: dialogueparser Cc:
Blocked By: Blocking:
Department:

Description (last modified by barra_parpg) (diff)

How to reproduce the bug

  • Construct a new Dialogue object passing the dialogue_sections parameter
  • Attempt to access the parameter (Dialogue.dialogue_sections)

Expected result

  • Return a list of dialogue sections

Actual result

  • AttributeError? is raised, as the actual attribute is called sections, not dialogue_sections

Fix

  • Rename dialogue_actions in the init method to sections. Patch included.
  • References to dialogue_sections also need to be changed to sections. Not included in the patch since I've made other modifications to the affected file which should not be published yet (dialogueparsers.py)

Attachments

dialogue.patch (2.0 KB) - added by Aspidites <aspidites@…> 8 years ago.
patch correcting discussed issue. affects dialogue.py

Change History

Changed 8 years ago by Aspidites <aspidites@…>

patch correcting discussed issue. affects dialogue.py

comment:1 Changed 8 years ago by barra_parpg

  • Description modified (diff)

comment:2 Changed 8 years ago by barra_parpg

  • Keywords dialogueparser added
  • Type changed from bug to enhancement

comment:3 Changed 8 years ago by barra_parpg

  • Description modified (diff)

comment:4 Changed 8 years ago by technomage

  • Owner changed from parpg to technomage
  • Status changed from new to assigned

comment:5 Changed 8 years ago by technomage

  • Status changed from assigned to closed
  • Resolution set to fixed

Patch applied via revision 690.

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.