Modify

Ticket #270 (closed enhancement: wontfix)

Opened 9 years ago

Last modified 9 years ago

Implement support for primary stats for player and non-player characters

Reported by: barra_parpg Owned by: parpg
Priority: major Milestone: Evaluation
Component: meta Version: trunk
Keywords: meta, character stats, primary Cc:
Blocked By: #278 Blocking:
Department: Programming

Description (last modified by barra_parpg) (diff)

Meta ticket note

This is a meta tickets for all tasks that are related to implementing support for primary stats, both for the player character as well as for any non-player character. It is recommend to create more detailed tickets for the subtasks outlined in this ticket as soon as you start working on them.

Character stats

We'll focus on implementing support for the primary character stats outlined here: http://wiki.parpg.net/Character_generation_and_stats#Primary_Stats

Character descriptions

Furthermore support for these basic character descriptions should be added as well:

  • Name of the character (already supported right now)
  • Age of the character (now supported yet)
  • Gender (not supported yet)

The secondary character stats are currently not fleshed out yet so there is no need to implement support for them at this point.

Subtasks

The task can be split up into three main subtasks:

  • Visualization of the primary character stats:
    • Create a GUI mockup how the character stats should look like ingame
    • After agreeing upon a GUI mockup, create (placeholder) art for the ingame character stats GUI
    • Create a pychan widget for the character stats that utilizes the (placeholder) art created for the purpose
  • Find a proper place where the character stats information should be stored. A good starting point would be adding the information to the agent yaml files in source:trunk/game/maps
  • Implement support for primary character stats:
    • Read character stats from file format
    • Modify character stats ingame (e.g. via console)
    • Save changes to character stats back to file format

Attachments

Change History

comment:1 Changed 9 years ago by barra_parpg

  • Component changed from scripts to meta

comment:2 Changed 9 years ago by barra_parpg

  • Description modified (diff)

comment:3 Changed 9 years ago by barra_parpg

  • Description modified (diff)

comment:4 Changed 9 years ago by barra_parpg

  • Description modified (diff)

comment:5 Changed 9 years ago by technomage

  • Blocked By 278 added

comment:6 Changed 9 years ago by barra_parpg

  • Department set to Programming

comment:7 Changed 9 years ago by barra_parpg

  • Description modified (diff)

comment:8 Changed 9 years ago by barra_parpg

  • Status changed from new to closed
  • Resolution set to wontfix
  • Milestone changed from Release: Techdemo 2 to Evaluation

Closing it for the time being as it's a duplicate of #264 and we want to avoid writing down implementation details before a user story gets tackled in a sprint.

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.