Modify

Ticket #245 (closed bug: fixed)

Opened 10 years ago

Last modified 10 years ago

Container animation not playing when same container is opened multiple times

Reported by: beliar Owned by: beliar
Priority: minor Milestone: Techdemo 1
Component: scripts Version: trunk
Keywords: Cc:
Blocked By: Blocking:
Department:

Description

When the same animated footlocker is opened multiple times the animation does not play anymore.

This is caused by the call to self.hide_container in create_box_gui in hud.py which itself calls box_container.container.close() which will close the container - but not the gui - thus playing the close animation since the change from the OPENING state to CLOSING state is a valid change.

This can be fixed by adding self.box_container = None at the end of hide_container which means that the code in hide_container will detect that it currently has to box_container and will not execute the close function. I have added a patch to the ticket that does just that.

Attachments

ContainerAnimationPatch.diff (546 bytes) - added by beliar 10 years ago.
Patch that fixes this bug

Change History

Changed 10 years ago by beliar

Patch that fixes this bug

comment:1 Changed 10 years ago by beliar

  • Status changed from new to assigned

comment:2 Changed 10 years ago by eliedebrauwer

  • Status changed from assigned to closed
  • Resolution set to fixed

(In [467]) Ticket #245: Patch by Belgiar. Fixes open animation when a container is opened multiple times. closes #245

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.