Modify

Ticket #226 (closed bug: fixed)

Opened 9 years ago

Last modified 9 years ago

inventory window item handling broken

Reported by: eliedebrauwer Owned by: eliedebrauwer
Priority: major Milestone: Techdemo 1
Component: scripts Version: trunk
Keywords: Cc:
Blocked By: Blocking:
Department:

Description

at this point you can do all sorts of crazy things with the inventory. If you open the inventory window you can for example select a hand icon and put it in the inventory, this way you can generate an infinite number of hands. You can even put these in crates. Also you can infinitely stack them on top of each other.

Put a feet over a hand an the hand will disappear (you would expect the feet would be dropped and the hand would become the one being held by the mouse.

Might be related to ticket #107.

Attachments

Change History

comment:1 Changed 9 years ago by b0rland_parpg

  • Owner changed from parpg to eliedebrauwer

I think this should be fixed by now. Please see if you can reproduce it.

comment:2 Changed 9 years ago by eliedebrauwer

This is partly finished, it is true that at this point you cannot get more items than those that exist. However it is still possible to allow items to disappear.

How to reproduce:

  • start the game
  • open the inventory
  • you have two daggers
  • drag the first dagger to the left arms slot
  • now drag the second dagger on top of the previous dagger
  • both daggers are now contained within the same arms slot (and you can only get one out).

comment:3 Changed 9 years ago by b0rland_parpg

The problem was due to a flaw in inventory gui refreshing (or lack of). In reality when the second dagger is put into slot, the first one returns to backpack. Unfortunately backpack wasn't previously redrawn so there was no way to see that. Applied a patch to fix that.

comment:4 Changed 9 years ago by b0rland_parpg

  • Status changed from new to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.